Due to the holidays, responses may be delayed.

  • Resolved

Cr80 Rfid Hotel 56mhz com Mifare Classic Thonsen Blank 1k Amazon 13 wxP1pEU

Prodigy Thonsen Rfid Amazon Mifare 56mhz Classic 1k Blank com Hotel Cr80 13 160 points

Part Number: AM5718

Tool/software: Linux

SDK: Processor SDK Linux 4.00

We recently did a board spin. The main difference between old and new board are:

1. Moved from AM5718 SR 1.0 to SR 2.0

2. Earlier design has CPU board plugged into the main board. The new design has integrated both boards.

On the old board, USB peripheral configured as Ethernet works fine. We are having trouble in making it work on the new board. 

Messages in the dmesg (old board): Messages highlighted bold does not appear on the new board.

[email protected]:~# dmesg | egrep -i "usb | g_ether"
[ 0.611443] LDOUSB: supplied by VDD_5V0_IN
[ 4.964414] udc-core: couldn't find an available UDC - added [g_ether] to list of pending drivers
Cr80 Hotel 56mhz com Thonsen Classic Mifare Blank 1k 13 Rfid Amazon com Hotel 56mhz 13 1k Mifare Blank Cr80 Rfid Amazon Thonsen Classic
[ 12.237711] extcon-usb-gpio extcon_usb1: GPIO lookup for consumer id
[ 12.237716] extcon-usb-gpio extcon_usb1: using device tree for GPIO lookup
[ 12.237764] of_get_named_gpiod_flags: parsed 'id-gpios' property of node '/extcon_usb1[0]' - status (0)
[ 12.237775] extcon-usb-gpio extcon_usb1: GPIO lookup for consumer vbus
[ 12.237778] extcon-usb-gpio extcon_usb1: using device tree for GPIO lookup
[ 12.237782] of_get_named_gpiod_flags: can't parse 'vbus-gpios' property of node '/extcon_usb1[0]'
[ 12.237785] of_get_named_gpiod_flags: can't parse 'vbus-gpio' property of node '/extcon_usb1[0]'
[ 12.237788] extcon-usb-gpio extcon_usb1: using lookup tables for GPIO lookup
[ 12.237792] extcon-usb-gpio extcon_usb1: lookup for GPIO vbus failed
[ 14.069734] usb0: HOST MAC 8e:a0:8a:7a:f3:bc
[ 14.201715] usb0: MAC 00:1e:58:41:b8:78
[ 14.231352] g_ether gadget: Ethernet Gadget, version: Memorial Day 2008
[ 14.248592] g_ether gadget: g_ether ready
[ 14.337535] usbcore: registered new interface driver usbfs
[ 14.351737] usbcore: registered new interface driver hub
[ 14.363504] usbcore: registered new device driver usb
[ 14.419030] xhci-hcd xhci-hcd.0.auto: new USB bus registered, assigned bus number 1
[ 14.463382] hub 1-0:1.0: USB hub found
[ 14.478774] xhci-hcd xhci-hcd.0.auto: new USB bus registered, assigned bus number 2
[ 14.487271] usb usb2: We don't know the algorithms for LPM for this host, disabling LPM.
[ 14.498089] hub 2-0:1.0: USB hub found
[ 15.784750] IPv6: ADDRCONF(NETDEV_UP): usb0: link is not ready
[ 639.617277] g_ether gadget: full-speed config #1: CDC Ethernet (ECM)
Rfid 1k Cr80 Mifare Blank Amazon com 13 Thonsen Hotel 56mhz Classic
[ 640.089222] IPv6: ADDRCONF(NETDEV_CHANGE): usb0: link becomes ready

 

Related configuration in the DTS file:

extcon_usb1: extcon_usb1 {
pinctrl-names = "default";
pinctrl-0 = <&extcon_usb1_default>;
compatible = "linux,extcon-usb-gpio";
id-gpios = <&gpio8 16 GPIO_ACTIVE_HIGH>;
};

...

extcon_usb1_default: extcon_usb1_default {
pinctrl-single,pins = <
0x21c (PIN_INPUT_PULLUP | MUX_MODE14) /* vout1_d16.gpio8_16 : Fake USB1-ID : GPIO 240 */
>;
};

...

&omap_dwc3_1 {
extcon = <&extcon_usb1>;
};

&usb1 {
dr_mode = "peripheral";
maximum-speed = "high-speed";
};

Looking into the schematic, there is no VBUS detection mechanism via PMIC. However, this is the case with the old board as well, still USB Ethernet works on the old board.

With Id Buy purchase Holograms Photo Fake Student Id n4napqH
Cr80 Rfid Hotel 56mhz com Mifare Classic Thonsen Blank 1k Amazon 13 wxP1pEU Cr80 Rfid Hotel 56mhz com Mifare Classic Thonsen Blank 1k Amazon 13 wxP1pEU
X39nGPTZkyVemM:Amazon.com: THONSEN CR80 13.56MHz MIFARE Classic 1K Blank RFID Hotel ...